12
28
2015
0

POJ1961 -- Period

Period

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

 
题目大意:给定一个字符串,求其前缀的循环节数k(输出 k > 1 的情况)
 
KMP     同POJ2406
 
#include <cstdio>
const int MaxL = 1000010;
int len, cnt;
int p[MaxL];
char s[MaxL];
int main()
{
	for (;;) {
		scanf("%d", &len);
		if (!len) break;
		scanf("%s", s + 1);
        printf("Test case #%d\n", ++cnt);
        int j = 0; p[1] = 0;
        for (int i = 2; i <= len; ++i) {
        	while (j && s[j + 1] != s[i]) j = p[j];
        	if (s[j + 1] == s[i]) ++j;
        	p[i] = j;
        	if (p[i] && i % (i - p[i]) == 0) printf("%d %d\n",i, i / (i - p[i]));
		}
		printf("\n");
	}
} 

 

Category: POJ | Tags: POJ 字符串 KMP | Read Count: 450

登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter

Host by is-Programmer.com | Power by Chito 1.3.3 beta | Theme: Aeros 2.0 by TheBuckmaker.com